Dominion® KX II-101-V2
Quick Setup Guide
Thank you for your purchase of the KX II-101-V2, the industry's most full-featured, enterprise-class, secure, digital KVM (Keyboard,
Video, Mouse) switch.
This Quick Setup Guide explains how to install and configure the KX II-101-V2. For additional information on any aspect of KX
II-101-V2, see the accompanying KX II-101-V2 User Guide, which can be downloaded from the Firmware and Documentation section
(http://www.raritan.com/support/firmware-and-documentation/) of Raritan's website.

Step 1: Configure the Target Server
For optimal bandwidth efficiency and video performance, a
target server running a graphical user interface such as
Windows, X-Windows, Solaris, and KDE should be configured
with desktop backgrounds set to a predominantly solid,
light-colored graphic. Backgrounds featuring photos or
complex gradients should be avoided.
Ensure that the server's video resolution and refresh rate are
supported by the KX II-101-V2, and that the signal is
non-interlaced. The KX II-101-V2 supports the following video
resolutions:

Resolutions
640x350 @70 Hz

720x400 @85 Hz

1024x768 @90 Hz

640x350 @85 Hz

800x600 @56 Hz

1024x768 @100 Hz

640x400 @56 Hz

800x600 @60 Hz

1152x864 @60 Hz

640x400 @84 Hz

800x600 @70 Hz

1152x864 @70 Hz

640x400 @85 Hz

800x600 @72 Hz

1152x864 @75 Hz

640x480 @60 Hz

800x600 @75 Hz

1152x864 @85 Hz

640x480 @66.6 Hz 800x600 @85 Hz

1152x870 @75.1 Hz

640x480 @72 Hz

800x600 @90 Hz

1152x900 @66 Hz

640x480 @75 Hz

800x600 @100 Hz

1152x900 @76 Hz

640x480 @85 Hz

832x624 @75.1 Hz

1280x960 @60 Hz

640x480 @90 Hz

1024x768 @60 Hz

1280x960 @85 Hz

640x480 @100 Hz

1024x768 @70 Hz

1280x1024 @60 Hz

640x480 @120 Hz

1024x768 @72 Hz

1280x1024 @75 Hz

720x400 @70 Hz

1024x768 @75 Hz

1280x1024 @85 Hz

720x400 @84 Hz

1024x768 @85 Hz

1600x1200 @60 Hz
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Mouse Modes
The KX II-101-V2 operates in several mouse modes: Absolute
Mouse Synchronization™, Intelligent Mouse mode and
Standard Mouse mode.
Note: Do not use an animated mouse while using Intelligent
Mouse mode.
Mouse parameters do not have to be altered for Absolute
Mouse Synchronization. For both the Standard and Intelligent
Mouse modes, mouse parameters must be set to specific
values, which are described in this section.
Mouse configurations will vary on different target operating
systems. Consult your OS documentation for additional
details.

Microsoft Windows 7 and Windows Vista Settings
To configure KVM target servers running Windows
Vista® operating system:
1. Configure the mouse settings:
a. Choose Start > Settings > Control Panel > Mouse.
b. Select "Advanced system settings" from the left
navigation panel. The System Properties dialog opens.
c. Click the Pointer Options tab.
d. In the Motion group:
 Set the mouse motion speed setting to exactly the
middle speed.
 Disable the "Enhanced pointer precision" option.
 Click OK.
2. Disable animation and fade effects:
a. Select the System option from the Control Panel.
b. Select Performance Information then Tools >
Advanced Tools > Adjust to adjust the appearance and
performance of Windows.
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c. Click the Advanced tab.
d. Click the Settings button in the Performance group to
open the Performance Options dialog.
e. Under Custom options, deselect the following
checkboxes:
 Animation options:
 Animate controls and elements inside windows
 Animate windows when minimizing and maximizing
 Fade options:
 Fade or slide menus into view
 Fade or slide ToolTips into view
 Fade out menu items after clicking
3. Click OK and Close the Control Panel.
To configure KVM target servers running Windows 7®
operating system:
1. Configure the mouse settings:
a. Choose Start > Control Panel > Hardware and Sound
> Mouse.
b. Click the Pointer Options tab.
c. In the Motion group:
 Set the mouse motion speed setting to exactly the
middle speed.
 Disable the "Enhanced pointer precision" option.
 Click OK.
2. Disable animation and fade effects:
a. Select Control Panel > System and Security.
b. Select System and then select "Advanced system
settings" from the left navigation panel. The System
Properties dialog appears.
c. Click the Advanced tab.
d. Click the Settings button in the Performance group to
open the Performance Options dialog.
e. Under Custom options, deselect the following
checkboxes:
 Animation options:
 Animate controls and elements inside windows
 Animate windows when minimizing and maximizing
 Fade options:
 Fade or slide menus into view
 Fade or slide ToolTips into view
 Fade out menu items after clicking
3. Click OK and Close the Control Panel.

Windows XP, Windows 2003 and Windows 2008
Settings
To configure KVM target servers running Windows
XP®, Windows 2003® and Windows 2008®:

c. In the Motion group:
 Set the mouse motion speed setting to exactly the
middle speed.
 Disable the "Enhance pointer precision" option.
 Disable the Snap To option.
 Click OK.
2. Disable transition effects:
a. Select the Display option from the Control Panel.
b. Click the Appearance tab.
 Click the Effects button.
 Deselect the "Use the following transition effect for
menus and tooltips" option.
3. Click OK and close the Control Panel.
Note: For KVM target servers running Windows XP, Windows
2000 or Windows 2008, you may wish to create a user name
that will be used only for remote connections through the KX
II-101-V2. This will enable you to keep the target server's slow
mouse pointer motion/acceleration settings exclusive to the
KX II-101-V2 connection.
Windows XP, 2000, and 2008 login pages revert to preset
mouse parameters that differ from those suggested for
optimal KX II-101-V2 performance. As a result, mouse
synchronization may not be optimal for these screens.
WARNING! Proceed only if you are comfortable adjusting the
registry on Windows KVM target servers. You can obtain
better KX II-101-V2 mouse synchronization at the login pages
by using the Windows registry editor to change the following
settings: HKey_USERS\.DEFAULT\Control Panel\Mouse: >
MouseSpeed = 0;MouseThreshold 1=0;MouseThreshold
2=0.

Windows 2000 Settings
To configure KVM target servers running Microsoft
Windows 2000® operating system:
1. Configure the mouse settings:
a. Choose Start > Control Panel > Mouse.
b. Click the Motion tab.
 Set the acceleration to None.
 Set the mouse motion speed setting to exactly the
middle speed.
 Click OK.
2. Disable transition effects:
a. Select the Display option from the Control Panel.
b. Click the Effects tab.
 Deselect the "Use the following transition effect for
menus and tooltips" option.
3. Click OK and close the Control Panel.

1. Configure the mouse settings:
a. Choose Start > Control Panel > Mouse.
b. Click the Pointer Options tab.
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Linux Settings
To configure KVM target servers running Linux®:


(Standard Mouse Mode only) Set the mouse acceleration
to exactly 1 and set the threshold to exactly 1. Enter the
following command: xset mouse 1 1. This should be set
for execution upon login.

Step 3: Connect the Equipment
The KX II-101-V2 has the physical connections described in
the diagram. Each letter in the diagram corresponds to a step
in the equipment connection process described here.

Sun Solaris Settings
Set the mouse acceleration value to exactly 1 and the
threshold to exactly 1. A target server running the Solaris
operating system must output VGA video (H-and-V sync, not
composite sync). Set this at the graphical user interface or
with the command line xset mouse a t where a is the
acceleration and t is the threshold.

Apple Macintosh Settings
Mac® works with the KX II-101-V2 'out of the box.' However,
you must use Absolute Mouse Synchronization and enable
Absolute Mouse mode and mouse scaling for Mac servers on
the KX II-101-V2 Port page.
To enable this setting:
1. Choose Device Settings > Port Configuration. The Port
Configuration Page opens.
2. Click the Port Name for the port you want to edit.
3. In the USB Connection Settings section, select the Enable
Absolute Mouse checkbox and the "Enable Absolute
mouse scaling for MAC server" checkbox. Click OK.

IBM AIX Settings
To configure KVM target servers running IBM AIX®:


Go to the Style Manager, click on Mouse Settings and set
Mouse Acceleration to 1.0 and Threshold to 3.0.
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Step 2: Configure Network Firewall Settings
To access the KX II-101-V2 through a network firewall, your
firewall must allow communication on TCP Port 5000.
Alternatively, the KX II-101-V2 can be configured to use a
different TCP port of your own designation.
To take advantage of the KX II-101-V2's web-access
capabilities, the firewall must allow inbound communication on
TCP Port 443 - the standard TCP port for HTTPS
communication. To take advantage of the KX II-101-V2's
redirection of HTTP requests to HTTPS (so that users may
type the more common, http://xxx.xxx.xxx.xxx, instead of
https://xxx.xxx.xxx.xxx), the firewall must also allow inbound
communication on TCP Port 80 - the standard TCP port for
HTTP communication.

Diagram key
Power
connector

Single power adapter.

KVM cable
with monitor,
PS/2 and
USB
connectors
(included)

Attach the KVM cable to connect the
device to a monitor and to a target
server.

Ethernet LAN Provides LAN connectivity.
Admin port

Use to do one of the following:





Local port

Configure and manage the
device with a terminal emulation
program on your PC.
Configure and manage a power
strip (requires an adapter, not
included).
Connect an external modem to
dial into the device.

The local port connects to a monitor.
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A: Power

Diagram key for USB Connection

The KX II-101-V2 is powered by a 100-240V AC input and
5VDC output power adaptor that is included with the device.
For standard AC power, plug the included AC power adaptor
into the Power port and plug the other end into a nearby AC
power outlet.

B: Target Server
Use either the PS/2 or USB to connect to the target. Before
connecting, configure your target server's video to a
supported resolution. Use the USB connection if you are using
virtual media or Absolute Mouse Mode.

USB Configuration

Local mouse and keyboard (optional)
Video connection from the KX II-101-V2 to
the target
USB connection from the KX II-101-V2 to the
target
Optional monitor connection from KX
II-101-V2 Local Port to the monitor
Optional USB connection from the target
server to the mouse and keyboard (cable not
included)

PS/2 Configuration

To configure the KX II-101-V2 for use with a USB
target server:
1. Use the attached video cable to connect the KX II-101-V2
to the target video port.
2. Connect the USB connector of the KVM cable to the KX
II-101-V2 and to a USB port on the target server.
3. Connect a monitor to the KX II-101-V2 Local Port if you
need to use the local video. Optional
4. Connect the USB keyboard and mouse directly to the
target. Optional
Note: If you are using virtual media, you must use the
USB connection.

Diagram key for USB Connection
KX II-101-V2
Target server

To configure the KX II-101-V2 for use with a PS/2
target server:
1. Use the attached video cable to connect the KX II-101-V2
to the target video port.
2. Connect the PS/2 connector of the KVM cable to a PS/2
port on the target.
3. Connect a monitor to the KX II-101-V2 Local Port if you
need to use the local video. Optional
4. If you have a PS/2 keyboard and mouse, use a PS/2 to
USB adapter (not included) to connect to the USB port of
the target directly. Optional
Note: If you are using virtual media, you must use the USB
connection.

Diagram key for PS/2 connections
KX II-101-V2

Local monitor (optional)
Target server
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Step 4: Configure the KX II-101-V2
Diagram key for PS/2 connections
Local monitor

Note: You must use a crossover cable between the KX
II-101-V2 and client if you are configuring the KX II-101-V2
through a web browser.

Local mouse and keyboard (optional)
Video connection from the KX II-101-V2 to the
target
KVM cable connection from the KX II-101-V2 to the
target server
Optional KX II-101-V2 to monitor connection
Optional PS/2 to USB adapter connection (cable
not included) from target to keyboard and mouse

Configure the KX II-101-V2 Using the Remote
Console
The KX II-101-V2 Remote Console is a web-based application
that enables you to configure the device prior to use and
manage it after it has been configured. Before configuring the
KX II-101-V2 using the Remote Console, you must have both
your workstation and the device connected to a network.
You can also use a terminal emulation program to configure
the KX II-101-V2. See Configure the KX II-101-V2 Using a
Terminal Emulation Program (Optional) (on page 7).

Setting a New Password
C: Network
Connect a standard Ethernet cable from the network port
labeled LAN to an Ethernet switch, hub or router. The LAN
LEDs that appear above the Ethernet connection indicate
Ethernet activity. The yellow one blinks while the KX II-101-V2
is in use, indicating IP traffic at 10 Mbps. The green light
indicates a 100 Mbps connection speed.

D: Admin Port
The Admin port enables you to perform configuration and
setup for the KX II-101-V2 using a terminal emulation program
like HyperTerminal. Use use one DB9M to DB9F straight
serial cable to connect from the KX II-101-V2 to the serial port
on your PC or laptop. The serial port communication settings
should be configured as follows:






115,200 Baud
8 data bits
1 stop bit
No parity
No flow control

E: Local User Port
The Local User port serves as a pass-through to the target
server video so that it connects directly to the monitor. The
local keyboard and mouse must be connected to target server
directly.
For USB configurations, only the local video connects to the
target server at the Local User port. The keyboard and mouse
connect directly to the target server using USB ports.
QS R ule
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When you first log into the Remote Console, you are
prompted to set a new password to replace the default. Then
you can configure the KX II-101-V2.
1. Log into a workstation with network connectivity to your
KX II-101-V2 device.
2. Launch a supported web browser such as Internet
Explorer® (IE) or Firefox®.
3. In the address field of the browser, enter the default IP
address of the device: 192.168.0.192.
4. Press Enter. The login page opens.
5. Enter the user name admin and the password raritan.
6. Click Login. The Change Password page is displayed.
7. Type raritan in the Old Password field.
8. Type a new password in the New Password field and the
Confirm New Password field. Passwords can be up to 64
characters long and can consist of English alphanumeric
and printable special characters.
9. Click Apply. You will receive confirmation that the
password was successfully changed.
10. Click OK. The Port Access page opens.

Assigning an IP Address
To assign an IP address:
1. In the KX II-101-V2 Remote Console, choose Device
Settings > Network. The Network Settings page opens.
2. In the Device Name field, specify a meaningful name for
your KX II-101-V2 device. You can enter up to 32
alphanumeric and special characters with no spaces.
3. In the IPv4 section, enter or select the appropriate
IPv4-specific network settings:
a. Enter the IP Address if needed. The default IP address
is 192.168.0.192.
b. Enter the Subnet Mask. The default subnet mask is
255.255.255.0.
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c. Enter the Default Gateway if None is selected from the
IP Auto Configuration drop-down.
d. Enter the Preferred DHCP Host Name if DHCP is
selected from the IP Auto Configuration drop-down.
e. Select the IP Auto Configuration. The following options
are available:
 None (Static IP) - This option requires that you
manually specify the network parameters.
This is the recommended option because the KX
II-101-V2 is an infrastructure device and its IP address
should not change.


DHCP - Dynamic Host Configuration Protocol is used
by networked computers (clients) to obtain unique IP
addresses and other parameters from a DHCP server.
With this option, network parameters are assigned by
the DHCP server. If DHCP is used, enter the Preferred
host name (DHCP only). Up to 63 characters.

4. Select the IP configuration from the IP auto configuration
drop-down list:
 None (Static IP) - This is the default and
recommended option because the KX II-101-V2 is an
infrastructure device and its IP address should not
change. This option requires that you manually specify
the network parameters.
 DHCP - With this option, network parameters are
assigned by the DHCP server each time the KX
II-101-V2 is booted.
5. Select Obtain DNS Server Address Automatically if DHCP
is selected and Obtain DNS Server Address is enabled.
When Obtain DNS Server Address Automatically, the DNS
information provided by the DHCP server will be used.
6. If Use the Following DNS Server Addresses is selected,
regardless of whether DHCP is selected or not, the
addresses entered in this section will be used to connect
to the DNS server.
Enter the following information if the Following DNS
Server Addresses option is selected. These addresses are
the primary and secondary DNS addresses that will be
used if the primary DNS server connection is lost due to
an outage.
a. Primary DNS Server IP Address
b. Secondary DNS Server IP Address
7. When finished, click OK. Your KX II-101-V2 device is
now network accessible. Remove the crossover cable and
connect the KX II-101-V2 to the switch using a Cat5 cable.

Naming a Target Server
1. Attach the KX II-101-V2 to the target server.
2. Choose Device Settings > Port Configuration. The Port
Configuration page opens.
3. Click the Port Name for the target server. The Port page
opens.
4. Type a name, up to 32 alphanumeric and special
characters.
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5. Click OK.

Creating User Groups and Users
As part of the initial configuration, you must define user
groups and users in order for users to access the KX
II-101-V2.
The KX II-101-V2 uses system-supplied default user groups
and allows you to create groups and specify the appropriate
permissions to suit your needs.
User names and passwords are required to gain access to the
KX II-101-V2. This information is used to authenticate users
attempting to access your KX II-101-V2.
To add a new user group:
1. Open the Group page by selecting User Management >
Add New User Group or clicking the Add button from the
User Group List page.
The Group page is organized into the following categories:
Group, Permissions, Port Permissions, and IP ACL.
2. Type a descriptive name for the new user group into the
Group Name field.
3. Set the permissions for the group. Select the checkboxes
before the permissions you want to assign to all of the
users belonging to this group.
4. Set the port permissions. Specify the server ports that can
be accessed by users belonging to this group (and the
type of access).
5. Set the IP ACL. This feature limits access to the KX
II-101-V2 device by specifying IP addresses. It applies
only to users belonging to a specific group, unlike the IP
Access Control list feature that applies to all access
attempts to the device (and takes priority). Optional
6. Click OK.
To add a new user:
1. Open the User page by choosing User Management >
Add New User or clicking the Add button on the User List
page.
2. Type a unique name in the Username field (up to 16
characters).
3. Type the person's full name in the Full Name field (up to
64 characters).
4. Type a password in the Password field and retype the
password in the Confirm Password field (up to 64
characters).
5. Choose the group from the User Group drop-down list.
The list contains all groups you have created in addition to
the system-supplied default groups. <Unknown>, which is
the default setting, Admin, Individual Group.
If you do not want to associate this user with an existing
User Group, select Individual Group from the drop-down
list. For more information about permissions for an
Individual Group.
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6. To activate the new user, select the Active checkbox. The
default is activated (enabled).
7. Click OK.

Command Argument
ipauto

none|dhcp

Configure the KX II-101-V2 Using a Terminal
Emulation Program (Optional)
You can use the Admin serial console with a terminal
emulation program like HyperTerminal to set the following
configuration parameters for the KX II-101-V2:







dhcp - Automatically assign
an IP address to the device
on startup.
interface ipauto dhcp
ip

IP address

The IP address to assign to
the device. To manually set
an IP address for the first
time, this command must be
used with the ipauto
command and the none
option. See ipauto for
information. After you have
manually assigned an IP
address once, you can use
the ip command alone to
change the IP address.

mask

subnet mask

Command column should be
"interface"

For demonstration purposes, the terminal emulation program
described in this section is HyperTerminal. You can use any
terminal emulation program.
To use a terminal emulation program to configure the
KX II-101-V2:
1. Connect the KX II-101-V2 to a local PC.
2. Connect to the Admin port on the KX II-101-V2 and the
COM1 port on the PC.
3. Launch the terminal emulation program you want to use to
configure the KX II-101-V2.
4. Set the following port settings in the terminal emulation
program:
 Bits per second - 115200
 Data bits - 8
 Parity - None
 Stop bits - 1
 Flow control - None
5. Connect to the KX II-101-V2. The login page opens.
6. Type the administrator username and press Enter. You
are prompted to enter your password.
7. Type the default administrator name admin and press
Enter. You are promoted to enter your password.
8. At the Admin Port > prompt, type config and press Enter.
9. At the Config > prompt, type network and press Enter.
10. To view the current interface settings, at the Interface >
prompt, type interface and press Enter. The current
interface settings appear.
11. To configure new network settings, at the Network prompt,
type interface followed by one of the following commands
and its appropriate argument (option), then press Enter.

none - Enables you to
manually specify an IP
address for the device. You
must follow this option with
the ip command and the IP
address, as shown in the
following example:
interface ipauto none ip
192.168.50.12

IP address
Subnet mask address
Gateway address
IP autoconfiguration
LAN speed
LAN interface mode

To use a terminal emulation program with the KX II-101-V2,
you must first connect the included RS-232 serial cable from
the Admin port on the KX II-101-V2 to a COM port on your
PC.

Options

interface | ip | ...
interface | mask | The subnet
mask IP address
interface | gw
| The
gateway IP address
interface | mode

| ....

gw

IP address

The gateway IP address

mode

mode

The Ethernet mode. You
have the following choices:
auto - Automatically sets
speed and interface mode
based on the network.
10hdx - 10 MB/s, half duplex.
10fdx - 10 MB/s, full duplex
100hdx - 100 MB/s, half
duplex
100fdx - 100 MB/s, full duplex

When you have successfully changed a setting, you see a
confirmation message like the following:
Admin Port > config
Admin Port > Config > network
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Admin Port > Config > Network > interface ipauto
none ip 192.168.50.126
Network interface configuration successful.
When you are finished configuring the KX II-101-V2, type
logout at the command prompt and press Enter. You are
logged out of the command line interface.
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Additional Information
For more information about the KX II-101-V2 and the entire
Raritan product line, see Raritan's website (www.raritan.com).
For technical issues, contact Raritan Technical Support. See
the Contact Support page in the Support section on Raritan's
website for technical support contact information worldwide.
Raritan's products use code licensed under the GPL and LGPL. You can request a
copy of the source code. For details, see the Open Source Software Statement at
(http://www.raritan.com/about/legal-statements/open-source-software-statement/)
on Raritan's website.
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